Choropleth Location Text Not Displaying


I’m using arrays contained in a JSON object to plot my choropleth. For some reason, it displays “Trace 49” for the location text. How can I change this text to the full state name or remove it completely?

Here’s the graph:

Here’s the code:


Simply set hoverinfo: 'location+z+text'

more info:


The trace is still present in the graph in the transparent cell. Is it possible to remove it entirely and just display the hover info in the shaded area I showed in the first post?


Setting opacity: 0 in the corresponding trace object should do the trick.