Dash datatable dropdown doesn't work


#1

Hi, the DataTable dropdowns doesn’t seem to be working. I run the full code as provided on the website, but it doesn’t show the dropdown.
I am guessing that it is related to the updates. when I run the code with earlier versions of dash and dash_table, it works.
Thanks,


#2

Thanks for reporting!

The docs use the version that is mentioned in the installation instructions: https://dash.plot.ly/installation. We’ll update the docs with the new version shortly & and the new syntax.

The main change happened in 3.2.0: https://github.com/plotly/dash-table/blob/master/CHANGELOG.md#changed-1, where you’ll need to change 'type': 'dropdown' to 'presentation': 'dropdown' inside your columns list.


#3

Thanks so much Chris, it works now.
Just two small additional things I noticed; the dropdown in the first row does not show the dropdown menu if the cell height is bigger than 60px (I am trying to put small images by each row, and I want to have the cells aligned with them). Second, by default the content of the dropdown cell stays at the top, while those of other cells are are in the middle (This is an issue only when the cell height is bigger than a row height I guess)

Thanks again