Deprecation warning


#1

hi everybody,
I try to plot data in plotly via streaming using python (script), but the folowing warnning (clic here)cause execemtion and stop data sending.
Please what can i do to avoid this DepreacationWarning ??


#2

Hi @noureddiuno,

The reason you’re getting the deprecation warning is the use of the Data, Stream, YAxis, and Marker classes from:

from plotly.graph_objs import Scatter, Layout, Figure, Data, Stream, YAxis, Marker

These should be replaced by the classes suggested by the deprecation warnings.
-Jon


#3

Thank you @jmmease for your fast reponse,

I made some changes in libs import, it soved part of problem but “from plotly.graph_objs import Data” still shows warnning !!

I don’t inderstand why my programs ran very well before 25 october 2018 (without any of previous warnnigs) ?

yours sincerely.


#4

Hi @noureddiuno,

The deprecation warnings starting in version 3.0. The plotly.graph_objs.Data class is no longer needed. It should be replaced with a simple list or tuple.

So change

data = Data([temp11])

to


data = [temp11]

Hope that helps,
-Jon