go.Layout error


#1

Getting an error while trying to create a barmode graph,

Traceback (most recent call last):
File “generate_report.py”, line 201, in
main()
File “generate_report.py”, line 195, in main
generated_report()
File “generate_report.py”, line 103, in generated_report
color=’#000
File “/Library/Python/2.7/site-packages/plotly/graph_objs/graph_objs.py”, line 375, in init
self.setitem(key, val, _raise=_raise)
File “/Library/Python/2.7/site-packages/plotly/graph_objs/graph_objs.py”, line 430, in setitem
value = self._value_to_graph_object(key, value, _raise=_raise)
File “/Library/Python/2.7/site-packages/plotly/graph_objs/graph_objs.py”, line 535, in _value_to_graph_object
raise exceptions.PlotlyDictValueError(self, path)
plotly.exceptions.PlotlyDictValueError: ‘title’ has invalid value inside ‘layout’

Path To Error: [‘title’]

Current path: []
Current parent object_names: []

With the current parents, ‘title’ can be used as follows:

Under (‘figure’, ‘layout’):

editType: layoutstyle
role: object

my code-snippet:

data=go.Data([trace1])
layout = go.Layout(
barmode=‘relative’,
title=‘app’,
xaxis=dict(title=‘Minutes’),
yaxis=dict(title=‘test’),
legend=dict(
traceorder=‘normal’,
font=dict(
family=‘sans-serif’,
size=19,
color=’#000
),
)
)


#2

Hi @vijgan,

This looks like an error message from plotly.py version < 3. Could you try updating (current version is 3.4.2)? I would also recommend checking to make sure that you don’t have the plotly package installed using both pip and conda.

-Jon