Multiple Page App - Google App Engine


#1

I’m also having trouble with this. I was able to deploy a single application. And I’m able to do the multiple dashboard application on a local server by following the directions under “Structuring a Multi-Page App” on this page. But as soon as I try to deploy it to Google App Engine, I get this error:

Updating service [default] (this may take several minutes)...failed.                                    
ERROR: (gcloud.app.deploy) Error Response: [9] 
Application startup error:
[2017-12-27 03:13:32 +0000] [1] [INFO] Starting gunicorn 19.7.1
[2017-12-27 03:13:32 +0000] [1] [INFO] Listening at: http://0.0.0.0:8080 (1)
[2017-12-27 03:13:32 +0000] [1] [INFO] Using worker: sync
[2017-12-27 03:13:32 +0000] [7] [INFO] Booting worker with pid: 7
Failed to find application: 'main'
[2017-12-27 03:13:38 +0000] [7] [INFO] Worker exiting (pid: 7)
[2017-12-27 03:13:38 +0000] [1] [INFO] Shutting down: Master
[2017-12-27 03:13:38 +0000] [1] [INFO] Reason: App failed to load.

I have tried so much to get this error to go away. I think I’ve tried every combination of code in app.yaml, app.py, and main.py. Let me know if it would help for me to post the code in these files. Here is my file structure:
app.py
main.py
apps


Multiple Dashboards?
#2

I would post the contents of your app.yaml; Never worked with the Google App Engine but I know its under their Cloud Platform and the error you are getting sounds related to one I received in configuring my app for Heroku with a faulty Procfile - so this might help given that the Plotly docs explain a Heroku deployment: https://content.nanobox.io/moving-from-heroku-to-google-cloud-platform/

Unless you already got this to work