On IE11 getting error SCRIPT5009: 'fetch' is undefined


#1

I’m getting an error when trying to open my app in IE v11.0.90

When I check the console window it shows the following error message:

SCRIPT5009: 'fetch' is undefined
File: dash_renderer.min.js, Line: 12, Column: 20225

I’m using dash_renderer 0.14.1, and my app uses tabs.


New version of dash-renderer causes "fetch not found" error in IE11 when redirecting user via callback
#2

Thanks for reporting! I just logged a potential bug here: https://github.com/plotly/dash-renderer/issues/87


#3

Ok thanks. Let me know if you need anything from me.


#4

Also getting this error. Is it possible @mbkupfer that loading scripts and stylesheets locally will fix it? I’m waiting on a push to staging to test the fix and that’s my next rabbit hole.


#5

My scripts and style sheets are local. I’m loading them from my assets folder.


#6

Sounds good. If I figure something out I’ll update, but it does look like they’re missing a polyfill over in the issue tracker on github.


#7

Is this a new issue? Have you seen this issue in previous versions?


#8

First time for me using Dash with IE-based internal clients (since about a week ago), so I don’t have a long historical perspective on the issue!


#9

I can confirm that this issue has been resolved. For others viewing this thread and also having IE issues: try first updating dash-renderer and see if that does the trick:

pip install -U dash-renderer


#10

Might want to pin it to the most recent non-release candidate release, since I believe those were put out before this fix.

pip install dash-renderer==0.14.3

#11

using -U will automatically install latest release that is on pypi. Why pin it if it may become obsolete?


#12

pipenv installs the release candidates from pypi even though 0.14.3 is chronologically newer. Don’t know if that’s the case with vanilla pip. This does put the onus on the user to unpin at an unspecified later date, but otherwise I know I wasn’t picking up 0.14.3 so offered this approach.


#13

Whoop then should be pipenv install dash-renderer==0.14.3 given the above caveat about the release candidates.


#14

And for future readers, a reminder you can always see the latest versions in the installation docs: https://dash.plot.ly/installation